Sending Delay for all Mailings
Incident Report for Higher Logic Platform
Resolved
All of the delays have been resolved.
Posted Feb 17, 2021 - 15:48 EST
Investigating
We are currently experiencing delays with sending all mailings. We ask that you do not stop your current sends as they will all be processed. With these delays you may also see delays in your tracking data and recommend viewing this tomorrow. We will continue to update this page every hour.
Posted Feb 17, 2021 - 13:56 EST