Members in Some Online Communities Receiving Following Emails for Threads they are not Following

Incident Report for Higher Logic Platform

Postmortem

What Happened

Higher Logic Online Communities users receive an informational “following” email when other
users contribute to message threads that they’ve initiated or to which they’ve responded, to
inform them of new discussion on the message thread. Members in some Online Communities
received these “following” emails for message threads to which they had not contributed,
including for communities they were not members of.

Root Cause
We incorrectly updated SQL query criteria used to determine recipients of following emails.
The altered criteria were used to exclude a subset of users based on their community email
subscription settings. The update to the SQL criteria caused that subset of users to be
included rather than excluded, which caused certain members to receive additional emails.

Corrective Actions

  • Code change that introduced the issue was backed out of the deployment and the re-
    deployment was completed

  • Code change that introduced the issue has been updated and is pending re-review and re-

Posted Feb 17, 2025 - 14:56 EST

Resolved

This incident has been resolved.
Posted Feb 12, 2025 - 13:08 EST

Investigating

We are currently investigating this issue.
Posted Feb 12, 2025 - 11:09 EST
This incident affected: Community.